PHP as ISAPI module under IIS: Extension problem

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Don: Bucknell Web Application Developer

    #1

    PHP as ISAPI module under IIS: Extension problem

    I've been scouring the Google Usenet archives, and I can find neither
    any article that addresses this question, nor any group that seems
    dead-on appropriate for asking it; I posted this in alt.php, but I've
    had no luck there.

    I have installed PHP 4.3.2 as an ISAPI module under IIS 5.1 on Windows
    XP Professional SP1. I have previously done this under IIS 5.0 on Windows
    2000 Professional several times, with no problems at all.

    This time, though, there is some problem with some (though not all) of
    the extensions I wish to use. I have added (uncommented, actually) the
    following lines in php.ini:
    extension = php_ldap.dll
    extension = php_sockets.dll

    Now, whenever I start the Web publishing service, a system dialog
    appears with the following message:
    Unknown(): Unable to load dynamic library
    'c:\windows\sys tem32\inetsrv\p hp_ldap.dll' - the specified module
    could not be found.

    Sure enough, I can call sockets methods, but not LDAP methods (I get
    'undefined function' errors, as expected). php_ldap.dll and
    php_sockets.dll are in the very same directory together, and have
    identical security settings. I've tried copying them to various other
    directories (and updating the extension_dir value in the php.ini
    file), but that has no effect. The very same thing happens, with the
    new path in the error dialog.

    Why would one load but not the other? Any suggestions would be
    appreciated.
    --
    Don Rea
    Bucknell University ISR
  • Dave Bell

    #2
    Re: PHP as ISAPI module under IIS: Extension problem

    Although you probably will not like it, I suggest you install Apache 2.x
    onto your Windows XP machine, not only is Apache 2.x much more stable on
    Windows now, its faster, and the PHP interface is faster as well. I
    highly recommend moving to a better web-server like Apache.

    Comment

    • Tracy Nelson

      #3
      Re: PHP as ISAPI module under IIS: Extension problem

      Don: Bucknell Web Application Developer wrote:[color=blue]
      > Now, whenever I start the Web publishing service, a system dialog
      > appears with the following message:
      > Unknown(): Unable to load dynamic library
      > 'c:\windows\sys tem32\inetsrv\p hp_ldap.dll' - the specified module
      > could not be found.[/color]

      Have you tried using regsvr32 to register the dll (if that's still necessary
      under XP)?


      Comment

      • Don: Bucknell Web Application Developer

        #4
        Re: PHP as ISAPI module under IIS: Extension problem

        > Although you probably will not like it, I suggest you install Apache 2.x[color=blue]
        > onto your Windows XP machine, not only is Apache 2.x much more stable on
        > Windows now, its faster, and the PHP interface is faster as well. I
        > highly recommend moving to a better web-server like Apache.[/color]

        Alas, the choice of web server is not up to me. I'm using this machine
        for development and testing for an IIS deployment environment at my
        day job. Believe me, if I could select the tools, I'd never wrestle
        with IIS or write another line of VBS again!

        Comment

        • Don: Bucknell Web Application Developer

          #5
          Re: PHP as ISAPI module under IIS: Extension problem

          > Have you tried using regsvr32 to register the dll (if that's still necessary[color=blue]
          > under XP)?[/color]

          The equivalent of running regsvr32 is what's happening when IIS is
          loading the PHP libraries at start up (or at the restart of the
          service). So, if I try registering the library by hand, I get that
          same error message from the system.

          The real mystery, to me, is why one of the libraries loads and the
          other doesn't.

          Comment

          Working...