Command Works in DOS but not in XCMDSHELL

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • joetig
    New Member
    • Jan 2013
    • 2

    #1

    Command Works in DOS but not in XCMDSHELL

    I have two different source locations. One has a file share assoicated with it and it works, the other is a UNC path to a NAS device and the file cannot be found. When I cut paste the XCMD to a dos window it works. Is there something related to the location, device, share that causes it to fail when running in XMDShell .
  • NeoPa
    Recognized Expert Moderator MVP
    • Oct 2006
    • 32669

    #2
    It's only a guess, but maybe XCMDShell runs as a service rather than as the operator themselves. In which case it generally has no rights to any network resources. Thus, a UNC reference would fail when run that way.

    Comment

    • joetig
      New Member
      • Jan 2013
      • 2

      #3
      Thanks, thought of that. I am assuming that XCMD shell runs under the service account that runs sql server. We have given the account read / write to that designation. I am thing that it requires more. My login is admin, so when I paste the copy into a dos window it works. I also tried doing a simple dir cmd and Access is denied.

      Comment

      • NeoPa
        Recognized Expert Moderator MVP
        • Oct 2006
        • 32669

        #4
        I hear what you're saying Joe, but it does sound really like that's the problem. That said, I have no access to your setup so I can only see part of the picture.

        Comment

        Working...