Windows 2k3 IIS locks up with mysqli

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • s_m_b

    #1

    Windows 2k3 IIS locks up with mysqli


    I'm trying to get a web site working that needs php_mysqli.dll, and having
    failed to get PHP5 to behave on Win 2k3, I rolled back to php 4.4
    Thing is, if I enable the mysqli extension, the site will not load.
    Without it, the site loads, but phpmyadmin forinstance, will not work.

    No sign of any excessive loading on the server while the site is failing to
    start up, but killing the php process off returns a CGI error almost
    instantly.

    (I've been working with IIS /asp/perl sites for years, but never touched
    php before)
  • Jerry Stuckle

    #2
    Re: Windows 2k3 IIS locks up with mysqli

    s_m_b wrote:
    I'm trying to get a web site working that needs php_mysqli.dll, and having
    failed to get PHP5 to behave on Win 2k3, I rolled back to php 4.4
    Thing is, if I enable the mysqli extension, the site will not load.
    Without it, the site loads, but phpmyadmin forinstance, will not work.
    >
    No sign of any excessive loading on the server while the site is failing to
    start up, but killing the php process off returns a CGI error almost
    instantly.
    >
    (I've been working with IIS /asp/perl sites for years, but never touched
    php before)
    >
    Hmmm, I've installed PHP on your type of system several times and not
    had a problem.

    My first question would be - why are you installing PHP as a CGI? The
    ISAPI interface is cleaner.

    Do you have the MySQL client libraries installed on the system and
    available to the IIS user (both path and security)?

    Anything in your event log?

    --
    =============== ===
    Remove the "x" from my email address
    Jerry Stuckle
    JDS Computer Training Corp.
    jstucklex@attgl obal.net
    =============== ===

    Comment

    Working...