xampp -- MySQL problems....

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Frances

    #1

    xampp -- MySQL problems....

    a few days ago I installed XAMPP in my Windows 2000 machine, it
    completely messed my existing MySQL installation.. I've had it installed
    for over a year now (4.1) have never had any problems with it whatsoever
    (I connect to it from Tomcat and from stand-alone Java classes), now
    since I installed XAMPP I cannot connect to it at all, cannot start
    service... I uninstalled XAMPP completely, and my MySQL server still
    doesn't work.. so why does XAMPP not come with a warning that it can
    mess up existing MySQL installations? can there be a version of it
    without MySQL (and thus without the demos that pull info from db?) I
    have spent two days now trying to fix this problem, and after trying to
    get help here and elsewhere I still have not been able to fix this..

    this is error I get (from .err file) when try to start service now:

    InnoDB: Error: log file .\ib_logfile0 is of different size 0 10485760
    bytes
    InnoDB: than specified in the .cnf file 0 5242880 bytes!
    060607 22:47:57 [ERROR] Can't init databases
    060607 22:47:57 [ERROR] Aborting

    060607 22:47:57 [Note] mysqld.exe: Shutdown complete

    was wondering if anybody has any idea how I can fix this (will problem
    be fixed, do you think, if I re-install 4.1 (although it won't be exact
    same version, will I be able to use my existing data with new
    installation..) ) thank you.. I'm very upset about this..... have
    spent so much time dealing with this problem.... :( thank you...
  • Virginner

    #2
    Re: xampp -- MySQL problems....

    "Frances" <fdr58@yahoo.co m> wrote in message
    news:44888ad9$0 $15791$14726298 @news.sunsite.d k...
    | a few days ago I installed XAMPP in my Windows 2000 machine, it
    | completely messed my existing MySQL installation.. I've had it installed
    | for over a year now (4.1) have never had any problems with it whatsoever
    | (I connect to it from Tomcat and from stand-alone Java classes), now
    | since I installed XAMPP I cannot connect to it at all, cannot start
    | service... I uninstalled XAMPP completely, and my MySQL server still
    | doesn't work.. so why does XAMPP not come with a warning that it can
    | mess up existing MySQL installations? can there be a version of it
    | without MySQL (and thus without the demos that pull info from db?) I
    | have spent two days now trying to fix this problem, and after trying to
    | get help here and elsewhere I still have not been able to fix this..
    |
    | this is error I get (from .err file) when try to start service now:
    |
    | InnoDB: Error: log file .\ib_logfile0 is of different size 0 10485760
    | bytes
    | InnoDB: than specified in the .cnf file 0 5242880 bytes!
    | 060607 22:47:57 [ERROR] Can't init databases
    | 060607 22:47:57 [ERROR] Aborting
    |
    | 060607 22:47:57 [Note] mysqld.exe: Shutdown complete
    |

    I'm sorry you have had problems.

    It came about as you installed MySQL 5 straight over a copy of MySQL 4.1.

    It can be solved by editing your my.ini file.

    Check the entry innodb_log_file _size=xxxxx

    and change it to innodb_log_file _size=10M which is what it's expecting.

    D.


    Comment

    • Frances

      #3
      Re: xampp -- MySQL problems....

      Virginner wrote:[color=blue]
      > "Frances" <fdr58@yahoo.co m> wrote in message
      > news:44888ad9$0 $15791$14726298 @news.sunsite.d k...
      > | a few days ago I installed XAMPP in my Windows 2000 machine, it
      > | completely messed my existing MySQL installation.. I've had it installed
      > | for over a year now (4.1) have never had any problems with it whatsoever
      > | (I connect to it from Tomcat and from stand-alone Java classes), now
      > | since I installed XAMPP I cannot connect to it at all, cannot start
      > | service... I uninstalled XAMPP completely, and my MySQL server still
      > | doesn't work.. so why does XAMPP not come with a warning that it can
      > | mess up existing MySQL installations? can there be a version of it
      > | without MySQL (and thus without the demos that pull info from db?) I
      > | have spent two days now trying to fix this problem, and after trying to
      > | get help here and elsewhere I still have not been able to fix this..
      > |
      > | this is error I get (from .err file) when try to start service now:
      > |
      > | InnoDB: Error: log file .\ib_logfile0 is of different size 0 10485760
      > | bytes
      > | InnoDB: than specified in the .cnf file 0 5242880 bytes!
      > | 060607 22:47:57 [ERROR] Can't init databases
      > | 060607 22:47:57 [ERROR] Aborting
      > |
      > | 060607 22:47:57 [Note] mysqld.exe: Shutdown complete
      > |
      >
      > I'm sorry you have had problems.
      >
      > It came about as you installed MySQL 5 straight over a copy of MySQL 4.1.[/color]
      [color=blue]
      > It can be solved by editing your my.ini file.
      >
      > Check the entry innodb_log_file _size=xxxxx
      >
      > and change it to innodb_log_file _size=10M which is what it's expecting.[/color]

      people keep telling me to change this var.. when I first looked at it
      yesterday it was already set to 10MB, today at someone's suggestion
      changed it to 20MB, none of it made any difference.. I think I will
      uninstall 4.1 and install it again, don't think I have any choice at
      this point, I think I have exhausted all options here now..

      and really I think XAMPP should come with a warning that this could
      happen if you already have MySQL installed, and I think there should be
      a verion of it w/o MySQL, so as not to cause these problems.. will have
      to opt for http://us2.php.net/get/php-5.1.4-Win.../from/a/mirror if
      want to do PHP any development on my machine, hopefully can it make it
      work with IIS, is probably simpler than spending a whole week figuring
      out how to config Apache.. oh man.. ok, Virginner, again, many thanks
      for your help.. Frances


      Comment

      • Virginner

        #4
        Re: xampp -- MySQL problems....

        | people keep telling me to change this var.. when I first looked at it
        | yesterday it was already set to 10MB, today at someone's suggestion
        | changed it to 20MB, none of it made any difference.. I think I will
        | uninstall 4.1 and install it again, don't think I have any choice at
        | this point, I think I have exhausted all options here now..
        |

        Are you putting 10M or 10MB ?


        Comment

        • Virginner

          #5
          Re: xampp -- MySQL problems....

          | people keep telling me to change this var.. when I first looked at it
          | yesterday it was already set to 10MB, today at someone's suggestion
          | changed it to 20MB, none of it made any difference.. I think I will
          | uninstall 4.1 and install it again, don't think I have any choice at
          | this point, I think I have exhausted all options here now..
          |
          | and really I think XAMPP should come with a warning that this could
          | happen if you already have MySQL installed, and I think there should be
          | a verion of it w/o MySQL, so as not to cause these problems.. will have
          | to opt for http://us2.php.net/get/php-5.1.4-Win.../from/a/mirror if
          | want to do PHP any development on my machine, hopefully can it make it
          | work with IIS, is probably simpler than spending a whole week figuring
          | out how to config Apache.. oh man.. ok, Virginner, again, many thanks
          | for your help.. Frances
          |

          (a) forgot... are you changing the right my.ini ? Make sure you don't have
          more than one, and make sure you put 10M not MB
          (b) when you install using XAMPP it *does* give you the option of whether
          you want to install MySQL.
          (c) I *still* suggest you scrub everything and use XAMPP. You can (assuming
          there are no bits of MySQL or Apache or anything else floating around) be up
          and running in 10 minutes flat. It's a hell of a lot easier than learning
          how to configure Apache (or IIS) to work with PHP to work with MySQL, as it
          does it all in one install. If you want to learn PHP, it's still the
          quickest way to do it.

          D.


          Comment

          • Frances

            #6
            Re: xampp -- MySQL problems....

            Virginner wrote:[color=blue]
            > | people keep telling me to change this var.. when I first looked at it
            > | yesterday it was already set to 10MB, today at someone's suggestion
            > | changed it to 20MB, none of it made any difference.. I think I will
            > | uninstall 4.1 and install it again, don't think I have any choice at
            > | this point, I think I have exhausted all options here now..
            > |
            > | and really I think XAMPP should come with a warning that this could
            > | happen if you already have MySQL installed, and I think there should be
            > | a verion of it w/o MySQL, so as not to cause these problems.. will have
            > | to opt for http://us2.php.net/get/php-5.1.4-Win.../from/a/mirror if
            > | want to do PHP any development on my machine, hopefully can it make it
            > | work with IIS, is probably simpler than spending a whole week figuring
            > | out how to config Apache.. oh man.. ok, Virginner, again, many thanks
            > | for your help.. Frances
            > |
            >
            > (a) forgot... are you changing the right my.ini ? Make sure you don't have
            > more than one, and make sure you put 10M not MB
            > (b) when you install using XAMPP it *does* give you the option of whether
            > you want to install MySQL.
            > (c) I *still* suggest you scrub everything and use XAMPP. You can (assuming
            > there are no bits of MySQL or Apache or anything else floating around) be up
            > and running in 10 minutes flat. It's a hell of a lot easier than learning
            > how to configure Apache (or IIS) to work with PHP to work with MySQL, as it
            > does it all in one install. If you want to learn PHP, it's still the
            > quickest way to do it.[/color]

            once again, thanks D... it DOES give you an option of whether or not
            you want MySQL??? I REALLY don't remember that.. I would have to see a
            screen-shot of it or something.. I don't remember that at all (& most
            probably I would have chosen 'no'...) I also don't see that option
            here, http://www.apachefriends.org/en/xampp-windows.html#522 (I mean
            does it install MySQL and then just give you option of not turning on
            service? that would also scare me.. or can you install just Apache and
            whatever you need for PHP without installing any MySQL stuff at all?
            (and I assume in that case it wouldn't install demos that pull info from
            db? that would make sense..) oh brother..

            ok, I did re-install MySQL 1.4.. can basically reconnect ok, only am
            having some problems (copied my db's back but can't read tables..), but
            that's for another forum.. again many thanks..

            Comment

            Working...