how to completely disable openbase_dir?

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • kevincw01

    #1

    how to completely disable openbase_dir?

    I'm using php 4.3.4 and have an intermitent problem with gallery
    (gallery.source forge.net) regarding the open_basedir restriction in
    php. The error I am getting is:
    ------
    PHP Warning: (null)(): Failed opening
    '/home/httpd/vhosts/mydom.com/httpdocs/gallery2/main.php' for inclusion
    (include_path=' .:/usr/share/pear') in Unknown on line 0, referer:
    http://mydom.com/gallery2/main.php
    ------
    I have disabled safemode and open_basedir in php.ini and have verified
    through a phpinfo() call that they are disabled. Actually,
    open_basedir is reported as being set to "no value" and safemode is
    reported as disabled.

    The strange thing is that this does not happen every time i access this
    page. It is only 1 out of 10 times and usually it is the first time i
    access the page for the day(but not always). I have restarted httpd
    and the server just in case. I also checked .htaccess but it shouldnt
    matter since phpinfo() says it is not set. This is baffling to me! If
    I could rip this feature out I would. It was installed by default on
    my dedicated server.

    Your help or tips are appreciated.

    -Kevin

Working...