Can't find MySQL extensions (PHP as CGI)

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • Unknown User

    #1

    Can't find MySQL extensions (PHP as CGI)

    Yesterday I did a fresh install of Apache 2, PHP5 as CGI and MySQL 4 on
    WinXP.
    Apache and PHP work fine, MySQL works fine in the command line, but I
    can't have PHP to find the MySQL extensions.

    I installed phpMyAdmin, and this is how I found out that PHP didn't find
    the extensions because I got this error message:

    "PHP Startup: Unable to load dynamic library 'C:/Arquivos de
    Programas/PHP5/php_mysql.dll'"

    I googled for this error message, and I didn't find anything useful
    because it seems that I don't have an extensions folder (?!)

    I searched for php_mysql.dll on my computer and I didn't find it. Did I
    forget to install extensions or something?

    These are the folders of the PHP installation folder:

    - sessiondata
    - uploadtemp

    And these are the files:

    - IISConfig.exe
    - install.txt
    - license.txt
    - php5ts.dll
    - php-cgi.exe

    It seems to me that there are files or folders missing...

    Thanks,

    --
    Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
Working...