Crystal report - WinApp : Cannot connect to Sql Server from Deployed machine

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • Shashi Sadasivan
    Recognized Expert Top Contributor
    • Aug 2007
    • 1435

    #1

    Crystal report - WinApp : Cannot connect to Sql Server from Deployed machine

    Hi,
    I have bumped into this issue where my application (which consistently reads the database) has to also create a crsytal report when requested.
    The crystal repost uses the same connection string as the application (i parsed the connection string and set the ConnectionInfo)
    However, the crystal report fails to logon and gives an exception :
    Code:
    Logon failed.
    Error in File Quote {E2D18712-BD5A-4EE7-867E-79F137EB549D}.rpt:
    Unable to connect: incorrect log on parameters.
    This is only occouring from a client machine (which is an ideal machine for deployment). The development machines run it perfectly (the ones with visual studio on them)

    I am using Crystal 2008 and have the runtime crystal12 installed on the client machine.

    I ran sql profiler and found that the crystal report does not query the database at all. (not even a failed login occours)

    I then transferred the database on the development machine and turned the firewall off on both the client and dev machine, still with absolutly no change.

    Is there any possible check / solution or suggestion which i could use to narrow out on what could be happening.
  • Shashi Sadasivan
    Recognized Expert Top Contributor
    • Aug 2007
    • 1435

    #2
    A solution was found.

    Installed the sql native client from which can be downloaded off the microsoft wesite and worked perfectly
    This is supposed to replace the MDAC, and seems crystal reports (2008) does not like MDAC.

    Comment

    Working...