Telerik & "Validation of viewstate MAC failed."

Collapse
This topic is closed.
X
X
 
  • Time
  • Show
Clear All
new posts
  • SpaceMarine

    #1

    Telerik & "Validation of viewstate MAC failed."

    hello,

    when my page attempts a Telerik RadGrid row insert (AJAX enabled) my
    page throws this exception:

    Validation of viewstate MAC failed. If this application is hosted by a
    Web Farm or cluster, ensure that <machineKeyconf iguration specifies
    the same validationKey and validation algorithm. AutoGenerate cannot
    be used in a cluster.

    ....my host, www.DataPacket.net, says the site is not on a webfarm, and
    that this error is due to my site exceeding the Application Pool
    resource limits set for it (site is on a shared hosting environment).

    can anyone confirm that this is possible? i dont know much about APs,
    but i am surprised that one page w/ one RadGrid thats attempting to
    insert one row via AJAX could cause my site to exceed CPU/RAM
    resource.

    any thoughts?


    thanks!
    sm =
  • =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=

    #2
    RE: Telerik &amp; &quot;Validatio n of viewstate MAC failed.&quot;

    It's possible but not that likely unless there is a whopper of a viewstate
    field in the page. More likely, the RAD control is modifying the viewstate in
    such a way that it fails the MAC check. You can disable this check in the
    web.config. I think it's <pages enableViewState MAC = "false" /or something
    like that.
    -- Peter
    Site: http://www.eggheadcafe.com
    UnBlog: http://petesbloggerama.blogspot.com
    Short Urls & more: http://ittyurl.net


    "SpaceMarin e" wrote:
    hello,
    >
    when my page attempts a Telerik RadGrid row insert (AJAX enabled) my
    page throws this exception:
    >
    Validation of viewstate MAC failed. If this application is hosted by a
    Web Farm or cluster, ensure that <machineKeyconf iguration specifies
    the same validationKey and validation algorithm. AutoGenerate cannot
    be used in a cluster.
    >
    ....my host, www.DataPacket.net, says the site is not on a webfarm, and
    that this error is due to my site exceeding the Application Pool
    resource limits set for it (site is on a shared hosting environment).
    >
    can anyone confirm that this is possible? i dont know much about APs,
    but i am surprised that one page w/ one RadGrid thats attempting to
    insert one row via AJAX could cause my site to exceed CPU/RAM
    resource.
    >
    any thoughts?
    >
    >
    thanks!
    sm =
    >

    Comment

    • SpaceMarine

      #3
      Re: Telerik &amp; &quot;Validatio n of viewstate MAC failed.&quot;

      On Apr 9, 12:30 pm, Peter Bromberg [C# MVP]
      <pbromb...@yaho o.NoSpamMaam.co mwrote:
      It's possible but not that likely unless there is a whopper of a viewstate
      field in the page. More likely, the RAD control is modifying the viewstatein
      such a way that it fails the MAC check. You can disable this check in the
      web.config. I think it's <pages enableViewState MAC = "false" /or something
      like that.
      unfortunately that property is already false -- false is the default.

      i know Telerik's RadGrid is pretty spiffy and uses a large
      viewstate... but how would the viewstate be connected to the App Pool
      for my site? i dont usually work w/ shared sites, so im not sure.

      thanks,
      matt

      Comment

      • SpaceMarine

        #4
        Re: Telerik &amp; &quot;Validatio n of viewstate MAC failed.&quot;

        On Apr 9, 3:20 pm, SpaceMarine <spacemar...@ma ilinator.comwro te:
        i know Telerik's RadGrid is pretty spiffy and uses a large
        viewstate... but how would the viewstate be connected to the App Pool
        btw i isolated the viewstate and looked at its size -- 8k. sound large
        enough to jack w/ my app pool?


        sm

        Comment

        • bruce barker

          #5
          Re: Telerik &amp; &quot;Validatio n of viewstate MAC failed.&quot;

          viewstate is an encrypted hidden field, client code does not touch it.
          the error means the server can not decrypt it. there are two causes:

          1) the data was changed
          2) the mac key has changed

          if the mac key is not specified in the web config, it is generated at
          startup. if your app pool is recycling (check the log) the key can change.

          -- bruce (sqlwork.com)

          SpaceMarine wrote:
          hello,
          >
          when my page attempts a Telerik RadGrid row insert (AJAX enabled) my
          page throws this exception:
          >
          Validation of viewstate MAC failed. If this application is hosted by a
          Web Farm or cluster, ensure that <machineKeyconf iguration specifies
          the same validationKey and validation algorithm. AutoGenerate cannot
          be used in a cluster.
          >
          ...my host, www.DataPacket.net, says the site is not on a webfarm, and
          that this error is due to my site exceeding the Application Pool
          resource limits set for it (site is on a shared hosting environment).
          >
          can anyone confirm that this is possible? i dont know much about APs,
          but i am surprised that one page w/ one RadGrid thats attempting to
          insert one row via AJAX could cause my site to exceed CPU/RAM
          resource.
          >
          any thoughts?
          >
          >
          thanks!
          sm =

          Comment

          • SpaceMarine

            #6
            Re: Telerik &amp; &quot;Validatio n of viewstate MAC failed.&quot;

            On Apr 9, 8:06 pm, bruce barker <nos...@nospam. comwrote:
            viewstate is an encrypted hidden field, client code does not touch it.
            the error means the server can not decrypt it. there are two causes:
            >
            1) the data was changed
            2) the mac key has changed
            >
            if the mac key is not specified in the web config, it is generated at
            startup. if your app pool is recycling (check the log) the key can change.
            not sure why youre referencing client code... im not concerned w/
            clientside code. im concerend w/ what my hosting company is telling
            me: that this error is due to my site pegging its app pool; which i
            find hard to believe because its a private site w/ a single user (me),
            doing a single thing (using this control w/ the 8k viewstate).

            they claim their servers are config'ed properly.


            sm

            Comment

            Working...