Sticky Session mode not working correctly for process taking long time

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • bharat mishra
    New Member
    • Jul 2014
    • 1

    #1

    Sticky Session mode not working correctly for process taking long time

    I have an implementation in which data needs to be exported to a file . Since size of data is very large therefore we display a progress bar that shows the progress status of records written so far . Now the problem is that this solution works fine in a single tomcat . But in clustering mode enabled with sticky session using Apache2.4.x process breaks and progress status changed from 74% suddenly to 0% . The issue is that primary session suddenly changes to backup and backup session becomes primary due to which sticky session is not working correctly as request gets redirected to another tomcat in between . As far as i know in sticky session request should always be redirected to tomcat having primary session . Why it is happening and what would be the solution ?? Any help in this regard will be very helpful.

    Following is an error log of apache::
    =============== =============== =============== =========
    proxy_ajp:error] [pid 1076:tid 8612] (OS 10060)A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.AH01030 : ajp_ilink_recei ve() can't receive header
    [Thu Jul 03 16:38:17.264208 2014] [proxy_ajp:error] [pid 1076:tid 8612] [client 192.168.7.76:64 085] AH00992: ajp_read_header : ajp_ilink_recei ve failed,
    Last edited by bharat mishra; Jul 7 '14, 06:25 AM. Reason: missed some crucial information
Working...